Degraded performance of Insight reports
Incident Report for Birch Grove Software, inc.
Resolved
This incident has been resolved.
Posted Feb 07, 2022 - 22:58 UTC
Identified
Our engineering team has identified an issue that affects performance of Insights reports and they are actively working on a resolution.
Posted Feb 07, 2022 - 15:48 UTC
This incident affected: Insights Report Dashboards.