UK account login issues
Incident Report for Birch Grove Software, inc.
Resolved
Login issue for UK accounts is now resolved.
Posted Apr 03, 2020 - 18:58 UTC
Investigating
Investigating issues with login to UK accounts.
Posted Apr 03, 2020 - 18:44 UTC
This incident affected: Frontend UI.