Degraded performance for Working Hours report
Incident Report for Birch Grove Software, inc.
Resolved
This incident has been resolved.
Posted May 13, 2021 - 14:35 UTC
Monitoring
A fix for slow performance of the Working Hours report has been deployed. We are currently monitoring our systems to ensure stability of the fix.
Posted May 12, 2021 - 20:59 UTC
Identified
Our engineering team has identified the root cause behind the slow performance for the working hours report. We are working on a fix for the problem and estimate a deployed fix within the next few hours.
Posted May 12, 2021 - 20:32 UTC
Investigating
We are currently investigating reports of slow performance for the Working Hours report. Our engineering team is investigating the issue.
Posted May 11, 2021 - 16:50 UTC
This incident affected: Frontend UI and Frontend API Servers.