Delay in Insight report subscription email delivery and downloadable PDF Insight reports

Incident Report for ActivTrak

Resolved

We are no longer seeing any delays in Insight report subscription email deliveries. We are also not seeing any errors with downloadable PDF Insight reports.
Posted Apr 24, 2025 - 13:49 UTC

Update

We're experiencing a delay in sending Insight report subscription emails and errors with downloadable PDF Insight Reports. We are continuing to looking into these issues.
Posted Apr 23, 2025 - 19:07 UTC

Investigating

We're experiencing a delay in sending Insight report subscription emails and are currently looking into the issue.
Posted Apr 22, 2025 - 19:58 UTC
This incident affected: Email Subscriptions.