Payment system major outage
Incident Report for Birch Grove Software, inc.
Resolved
The third party outage has been resolved.
Posted Jul 02, 2019 - 15:56 UTC
Monitoring
A fix has been implemented and our payment system is working as expected. We will continue to monitor the service to ensure full restoration has been completed.
Posted Jul 02, 2019 - 14:19 UTC
Identified
Our payment system has reported a major outage that affects all of their systems. During this outage, customers will not be able to upgrade their account or make any changes to their ActivTrak subscription.
Posted Jul 02, 2019 - 14:10 UTC
This incident affected: Third-party Components (Recurly API).