Reports of delayed or inconsistent data for some accounts
Incident Report for Birch Grove Software, inc.
Resolved
Our engineering team has applied a fix for this issue.
Posted Apr 22, 2021 - 04:34 UTC
Investigating
We are currently investigating reports of delayed or inconsistent data for some accounts. Our engineering team is investigating root cause.
Posted Apr 22, 2021 - 02:19 UTC