Increased latency and errors with reporting
Incident Report for Birch Grove Software, inc.
Resolved
Root cause identified and a fix has been deployed.
Posted Jul 10, 2020 - 16:18 UTC
Investigating
We are seeing an increase in reporting latency and error rate associated with reporting. We are investigating root cause.
Posted Jul 10, 2020 - 16:00 UTC
This incident affected: Frontend UI.