Delayed processing of insights and ActivConnect data for some accounts

Incident Report for ActivTrak

Resolved

The delays affecting insights and ActivConnect reporting data have been resolved. Processing has returned to normal and all data is up to date. We apologize for any inconvenience this may have caused.
Posted Apr 24, 2026 - 14:56 UTC

Identified

We have identified the cause of the delays affecting insights and ActivConnect reporting data for some accounts. Our engineering team is actively working on a resolution. We will provide further updates as progress is made.
Posted Apr 23, 2026 - 16:06 UTC

Investigating

Some users may be experiencing delays in insights and ActivConnect reporting data. Our engineering team is looking into the issue.
Posted Apr 23, 2026 - 15:09 UTC
This incident affected: API / ActivConnect.