Degraded performance of Insight reports
Incident Report for Birch Grove Software, inc.
Resolved
This incident has been resolved.
Posted Feb 04, 2022 - 23:54 UTC
Investigating
Our engineering team is actively investigating reports of degraded performance with Insights reporting
Posted Feb 03, 2022 - 15:12 UTC
This incident affected: Insights Report Dashboards.