Issues with the delivery of notification/verification emails

Incident Report for ActivTrak

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 14:23 UTC

Monitoring

Our engineering team has deployed a fix and they are monitoring email delivery. Email delivery may be delayed as the backlog is processed.
Posted Feb 25, 2026 - 23:07 UTC

Identified

Our engineering team has identified root cause and is working on a fix.
Posted Feb 25, 2026 - 20:29 UTC

Update

Our engineering team continues to investigate root cause of the email delivery failures.
Posted Feb 25, 2026 - 18:26 UTC

Investigating

Our engineering team is investigating reports of email delivery failures associated with signup.
Posted Feb 25, 2026 - 16:41 UTC
This incident affected: Web Application and Email Subscriptions.