Incorrect Watchdog user entry in Web Application

Incident Report for ActivTrak

Resolved

This incident has been resolved. The Watchdog user entry has been removed. No further action is required.
Posted Mar 20, 2026 - 21:14 UTC

Update

We are continuing to investigate this issue.
Posted Mar 20, 2026 - 18:20 UTC

Investigating

The Watchdog entry is tied to a background service that’s part of the ActivTrak agent. Its purpose is to monitor the agent and restart it if needed to ensure continuous data collection. It is not a real user, does not collect any additional data, and does not impact reporting or insights. We’re actively investigating why it may be appearing as a user profile and will resolve it. No action is required on your end, and there’s no impact to your service. Until this is resolved, it will consume a license.
Posted Mar 20, 2026 - 18:20 UTC
This incident affected: Web Application.