Accounts with more than 50 users may see some delay for incoming activity log data.
Incident Report for Birch Grove Software, inc.
Resolved
This incident has been resolved.
Posted Mar 14, 2019 - 18:02 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 14, 2019 - 15:19 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 14, 2019 - 15:19 UTC
This incident affected: Frontend API Servers.