Increased error rate associated with non-US region accounts

Incident Report for ActivTrak

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 18:18 UTC

Monitoring

Our engineering team was able to identify root cause and apply a fix. We are monitoring the results.
Posted Oct 03, 2025 - 17:55 UTC

Investigating

Our engineering team is seeing an increase in error rates associated with non-US region accounts.
Posted Oct 03, 2025 - 17:31 UTC
This incident affected: Web Application and Data Ingestion.