Errors on Screenshot History Page
Incident Report for Birch Grove Software, inc.
Resolved
The incident has been resolved.
Posted Dec 11, 2020 - 23:42 UTC
Monitoring
We have corrected the cause of the screenshot history page producing errors while loading screenshots. We will continue to monitor our systems for proper operation.
Posted Dec 11, 2020 - 21:07 UTC
Identified
We have identified the problem and working to correct the screenshot history page not loading correctly.
Posted Dec 11, 2020 - 21:00 UTC
Investigating
We are currently investigating an issue with the screenshot history page. Some accounts may experience problems loading screenshots.
Posted Dec 11, 2020 - 20:53 UTC
This incident affected: Frontend UI and Frontend API Servers.