Errors loading account dashboards and reports
Incident Report for Birch Grove Software, inc.
Resolved
This incident has been resolved.
Posted Apr 01, 2020 - 02:46 UTC
Identified
The issue with loading of account dashboards and reports has been identified. We are working on a fix and will update status when the fix is deployed.
Posted Mar 31, 2020 - 22:50 UTC
Investigating
We are currently investigating reports of errors with loading of account dashboards and reports.
Posted Mar 31, 2020 - 22:38 UTC
This incident affected: Frontend UI and Frontend API Servers.