Degraded performance on the Storage page
Incident Report for Birch Grove Software, inc.
Resolved
We have fixed the performance issue related to the Storage page for certain accounts.
Posted Jan 28, 2020 - 21:19 UTC
Identified
We are presently experiencing degraded performance for certain accounts on the Storage page located in the Accounts menu. A fix is actively being worked to address the issue.
Posted Jan 28, 2020 - 18:50 UTC
This incident affected: Frontend UI and Frontend API Servers.