ActivTrak Application Signup and Login Failures
Incident Report for Birch Grove Software, inc.
Resolved
All issues around account creation and login have been resolved with our third-party dependencies.

We have also deployed a change to our login process to bypass the dependencies in the event of another failure on their side. This increases the stability of our ActivTrak application.
Posted Dec 22, 2021 - 14:57 UTC
Monitoring
We were able to identify the root cause of the login issues was a failure in the AWS cloud service that in turn affected some of our third-party dependencies. AWS shows to be stable again and users are able to log into the ActivTrak application. We will continue to monitor the situation and ensure proper operation.
Posted Dec 22, 2021 - 14:29 UTC
Update
We are continuing to work on a fix that will allow users to log into the ActivTrak application.

New accounts will receive a failure message during the creation process. The account will be created but due to the issues with logging in, they will not be able to access the new account.
Posted Dec 22, 2021 - 14:11 UTC
Identified
We have identified the cause of the outage and working to correct it.
Posted Dec 22, 2021 - 12:44 UTC
Investigating
We are investigating reports of failures to log in to the ActivTrak application.
Posted Dec 22, 2021 - 12:34 UTC
This incident affected: Frontend UI.