Elevated error rates on the "Productivity By Location" report

Incident Report for ActivTrak

Resolved

The issue has been resolved and the "Productivity By Location" report is functioning correctly.
Posted Aug 31, 2026 - 21:43 UTC

Identified

The issue has been identified and we are testing the fix.
Posted Aug 31, 2026 - 20:50 UTC

Investigating

We're experiencing an elevated level of application errors on the "Productivity By Location" report and are currently looking into the issue.
Posted Aug 31, 2026 - 20:04 UTC
This incident affected: Web Application.