Issues with login and page load
Incident Report for Birch Grove Software, inc.
Resolved
This incident has been resolved.
Posted Jan 22, 2021 - 15:27 UTC
Investigating
We are currently investigating reports of login issues and failures associated with loading the app.
Posted Jan 22, 2021 - 15:01 UTC
This incident affected: Frontend UI.