Degraded performance when logging into app
Incident Report for Birch Grove Software, inc.
Resolved
This incident has been resolved.
Posted May 28, 2021 - 18:07 UTC
Identified
Our engineering team is currently investigating root cause of degraded performance associated with login to the app.
Posted May 27, 2021 - 17:30 UTC
This incident affected: Frontend API Servers.