Some customers may be experiencing delays with Insights
Incident Report for Birch Grove Software, inc.
Resolved
This incident has been resolved.
Posted Oct 29, 2021 - 15:20 UTC
Monitoring
Our engineering team is aware of Insights issues and are monitoring an issue with our cloud provider.
Posted Oct 28, 2021 - 19:55 UTC
This incident affected: Frontend UI.