Emails from support are received as SPAM
Incident Report for ActivTrak
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 20:41 UTC
Monitoring
We are aware that some of our communications are being treated as SPAM. Please check your SPAM folder if you are waiting to hear from our support.
Posted Mar 26, 2024 - 23:44 UTC