Delay in Insights Subscriptions

Incident Report for ActivTrak

Resolved

All subscriptions have been delivered and the issue is resolved.
Posted Jun 09, 2025 - 17:31 UTC

Investigating

Some customers have reported errors processing Insights Subscriptions. We are investigating the issue.
Posted Jun 09, 2025 - 17:16 UTC
This incident affected: Email Subscriptions.