Windows Agent download issues on Chrome
Incident Report for Birch Grove Software, inc.
Resolved
This incident has been resolved.
Posted Dec 15, 2020 - 16:51 UTC
Update
We are continuing to investigate this issue.
Posted Dec 14, 2020 - 18:38 UTC
Investigating
We are currently investigating issue with error message on agent download from Chrome.
FireFox and Edge working as expected.
Posted Dec 14, 2020 - 18:38 UTC
This incident affected: Agent Download.