Some customers may be seeing delays with Google and Outlook calendar data

Incident Report for ActivTrak

Resolved

This incident has been resolved.
Posted May 15, 2025 - 17:42 UTC

Monitoring

Some customers may see a delay in Google and Outlook calendar data. Our engineering team has identified the issue, provided a fix, and triggered a sync of the integration.
Posted May 14, 2025 - 19:04 UTC
This incident affected: Data Ingestion.