Increase error rates associated with group management settings page

Incident Report for ActivTrak

Resolved

Our engineering team has applied a fix and no longer see an increase in error rate.
Posted Oct 23, 2025 - 17:35 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 23, 2025 - 16:59 UTC

Investigating

Our engineering team is investigating an increase in error rates associated with group management settings pages.
Posted Oct 23, 2025 - 16:50 UTC
This incident affected: Web Application.