Payment System Degraded
Incident Report for Birch Grove Software, inc.
Resolved
Our payment vendor has completed the maintenance on the systems that we utilize.
Posted Feb 05, 2019 - 21:35 UTC
Monitoring
Users might experience various problems during payment processes. We are monitoring our payment vendor for updates to their system's status. All other ActivTrak features will not be affected.
Posted Feb 05, 2019 - 15:29 UTC
This incident affected: Third-party Components (Recurly API).