ActivTrak Windows Agent Download
Incident Report for Birch Grove Software, inc.
Resolved
We have verified the fix for the ActivTrak Windows agent downloads.
Posted Jul 11, 2019 - 20:28 UTC
Monitoring
We have identified the issue affecting the ActivTrak Windows agent downloads to the use of a Third Party service that is having problems. We have updated our download system to use a different facility to restore the ability to download the Windows agent. We will continue to monitor the download system to ensure all issues have been resolved.
Posted Jul 11, 2019 - 17:34 UTC
Investigating
We are investigating errors associated with downloading the ActivTrak Windows agent. Users trying to download the Windows agent may encounter an error.
Posted Jul 11, 2019 - 17:13 UTC
This incident affected: Agent Download.