Issues with screenshot retrieval
Incident Report for Birch Grove Software, inc.
Resolved
Our engineering team has identified the issue and deployed a fix.
Posted May 07, 2021 - 19:46 UTC
Investigating
We are investigating reports of issues with screenshot retrieval for some accounts. Engineering is actively investigating the issue and will provide updates as soon as the issue is identified.
Posted May 07, 2021 - 19:17 UTC
This incident affected: Frontend API Servers.