ActivTrak Login Failure
Incident Report for Birch Grove Software, inc.
Resolved
We were able to determine the cause of the login failures and all ActivTrak services are operational.
Posted Apr 08, 2020 - 17:52 UTC
Investigating
We are currently investigating reports of customers not being able to log into their ActivTrak account. We are working to uncover the source of the problem and implement a fix.
Posted Apr 08, 2020 - 14:11 UTC
This incident affected: Frontend UI.